Lead Docket US Environments Slowness
Resolved
Degraded performance
Lasted for 3h

This incident has been resolved.

Wed, Feb 21, 2024, 12:29 AM
3 months ago
Affected components
Updates

Resolved

This incident has been resolved.

Wed, Feb 21, 2024, 12:29 AM
3h earlier...

Monitoring

Lead Docket is now operated as expected. We will continue to monitor performance.

Tue, Feb 20, 2024, 09:19 PM
19m earlier...

Investigating

We are currently investigating slowness and intermittent issues on Lead Docket.

Tue, Feb 20, 2024, 09:00 PM