Degraded Performance for Single US Environment
Resolved
Degraded performance
Lasted for 2h

After monitoring we are confident this is issue is resolved for affected users.

Tue, Dec 12, 2023, 08:45 PM
5 months ago
Affected components
Updates

Resolved

After monitoring we are confident this is issue is resolved for affected users.

Tue, Dec 12, 2023, 08:45 PM
34m earlier...

Monitoring

We have identified the issue and have mitigated the underlying cause internally. We are monitoring the issue over the next hour to ensure full resolution.

Our teams will also be meeting regarding a long term plan to ensure this does not recur in future.

Tue, Dec 12, 2023, 08:11 PM
2h earlier...

Investigating

Incoming Emails are currently experiencing delivery issues in a single US environment. Our team is actively working to resolve this.

Please reach out to our support teams for assistance if you notice any issues at this time.

Tue, Dec 12, 2023, 05:55 PM