Higher than normal response times in a single US Environment
Resolved
Full outage
Lasted for 46m

This incident has been resolved.

Tue, Oct 31, 2023, 03:45 PM
6 months ago
Affected components
Updates

Resolved

This incident has been resolved.

Tue, Oct 31, 2023, 03:45 PM
18m earlier...

Monitoring

We have taken measures to alleviate the slowness for affected users. We are monitoring and continuing our investigation into the underlying cause to ensure this does not recur.

Tue, Oct 31, 2023, 03:26 PM
27m earlier...

Investigating

We are continuing to investigate this issue.

Tue, Oct 31, 2023, 02:59 PM

Investigating

We are actively investigating higher than normal response times in a single US environment.

Tue, Oct 31, 2023, 02:59 PM