Incoming Email Delay in a Single US Environment
Resolved
Degraded performance
Lasted for 2h

Incoming emails have returned to normal operation.

Tue, Sep 26, 2023, 07:00 PM
7 months ago
Affected components
Updates

Resolved

Incoming emails have returned to normal operation.

Tue, Sep 26, 2023, 07:00 PM
2h earlier...

Investigating

We are currently investigating reports of incoming email delays in a single US environment.

Tue, Sep 26, 2023, 04:35 PM