We are seeing slowness in one US environment.
Resolved
Degraded performance
Lasted for 2h

This incident has been resolved.

Thu, Jul 20, 2023, 05:39 PM
10 months ago
Affected components
Updates

Resolved

This incident has been resolved.

Thu, Jul 20, 2023, 05:39 PM
2h earlier...

Monitoring

A fix has been implemented and we are monitoring the results.

Thu, Jul 20, 2023, 03:39 PM