One US environment is experiencing intermittent slowness
Resolved
Degraded performance
Lasted for 1h

Everything has returned back to normal operation.

Wed, Jun 7, 2023, 04:43 PM
11 months ago
Affected components
Updates

Resolved

Everything has returned back to normal operation.

Wed, Jun 7, 2023, 04:43 PM
20m earlier...

Monitoring

The fix has been implemented and we are seeing speeds improve. We will continue to monitor throughout the day.

Wed, Jun 7, 2023, 04:22 PM
1h earlier...

Identified

We have identified the cause and are working to resolve as quickly as possible.

Wed, Jun 7, 2023, 02:46 PM