1 US Environment Experiencing Loading Issues and Slowness
Resolved
Degraded performance
Lasted for 3h

We have identified the root cause and are taking actions to prevent similar things from happening in the future.

Wed, May 17, 2023, 07:38 PM
1 year ago
Affected components
Updates

Resolved

We have identified the root cause and are taking actions to prevent similar things from happening in the future.

Wed, May 17, 2023, 07:38 PM
2h earlier...

Monitoring

We have resolved the issues affecting users, so all users should see regular speeds and performance regained. The team is still investigating the underlying cause, however, and will monitor until it is confirmed.

Wed, May 17, 2023, 04:55 PM
31m earlier...

Investigating

In one US environment, all areas of the application are experiencing slowness or degraded performance with loading. Teams have already worked to restore service and are beginning to see performance slowly improve. Updates will be shared again shortly.

Wed, May 17, 2023, 04:23 PM