Degraded Performance for Email Notification Delivery
Resolved
Degraded performance
Lasted for 1h

Emails are now delivering as normal.

Thu, Apr 4, 2024, 03:30 PM
1 month ago
Affected components
Updates

Resolved

Emails are now delivering as normal.

Thu, Apr 4, 2024, 03:30 PM
1h earlier...

Identified

We are experiencing degraded performance with our email notification deliveries. This is also affecting password reset emails and multi-factor authentication processes.

Thu, Apr 4, 2024, 02:30 PM