Project Access Down in One US Environment
Incident Report for Filevine
Postmortem

This incident occurred with a recache of permissions for users in the affected environment in the early morning hours on Tuesday 9/7/23 that affected customers ability to view projects within their accounts. 

By 6:00 am MST, engineers were looking into the problem and discussing ways to resolve as quickly as possible. 

Resolution was ultimately achieved for the majority of customers by early afternoon EST, with the final resolutions for some customers in the early evening EST.

The leadership team, engineering, and customer-facing employees are convening to review post-incident actions to be taken to improve processes and additional preventative measures shortly.

Posted Sep 07, 2023 - 10:51 MDT

Resolved
After monitoring throughout the day, the updates made were successful. All known issues are resolved. Please reach out to support if you are still seeing issues in this area.
Posted Sep 06, 2023 - 15:15 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 06, 2023 - 00:52 MDT
Update
Over 95% of users have been restored to the projects they need access to. We are continuing to work this evening to finish updates for all impacted users.
We are confident all users will have correct permissions tomorrow prior to the start of business. We will post an update this evening with final confirmation that this incident is fully resolved.
Our teams are also deploying the fix for the root cause of today's issue to ensure future incidents are prevented.
Posted Sep 05, 2023 - 16:52 MDT
Update
Majority of impacted users have had their permissions enabled. Our engineers are working through those which remain. We thank you for your patience!
Posted Sep 05, 2023 - 14:37 MDT
Update
Our teams are continuing the course to ensure users are able to regain access to projects. The affected environment has senior engineers assigned to the work, as well as all customer-facing teams doing all they can to ensure users are assisted in any way possible.

Full resolution is expected in the coming hours. Next update to confirm progress toward resolution at 2:30pm MDT.
Posted Sep 05, 2023 - 13:30 MDT
Update
We have continued with our efforts to ensure full access is regained for users. This work will continue throughout the day for affected users and they will be able to resume their activity as this progresses. We will be sending communication out to affected users with more information shortly.

Our teams have provided one workaround that users can leverage at this time: by adding users to projects they need access to, these users have been able to move forward with their work within the system.

Next update 1:00pm MDT.
Posted Sep 05, 2023 - 11:08 MDT
Identified
We have identified the issue and are working on a fix that will get access restored as fast as possible.
Posted Sep 05, 2023 - 09:17 MDT
Investigating
We are actively investigating an issue with Project access in one US environment.
Posted Sep 05, 2023 - 05:52 MDT
This incident affected: Filevine - US Environments (Projects, Search, Project Hub).