Incoming Email Delay in a Single US Environment
Incident Report for Filevine
Resolved
Incoming emails have returned to normal operation.
Posted Sep 26, 2023 - 13:00 MDT
Investigating
We are currently investigating reports of incoming email delays in a single US environment.
Posted Sep 26, 2023 - 10:35 MDT
This incident affected: Filevine - US Environments (Communication Features).