Lead Docket Severely Degraded
Incident Report for Filevine
Resolved
This incident has been resolved.
Posted Sep 16, 2023 - 16:32 MDT
Monitoring
Our provider has identified the issue and is monitoring.
Posted Sep 16, 2023 - 11:55 MDT
Investigating
We are currently investigating this issue.
Posted Sep 16, 2023 - 11:20 MDT
This incident affected: Lead Docket - US Environments (Web application) and Lead Docket - CA Environments (Web application).