Lead Docket Unavailable
Incident Report for Filevine
Resolved
This incident has been resolved.
Posted Aug 25, 2023 - 21:03 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 25, 2023 - 11:56 MDT
Investigating
We are currently investigating this issue.
Posted Aug 25, 2023 - 08:47 MDT
This incident affected: Lead Docket - US Environments (Web application).