Multiple Environments experiencing Slowness
Affected components
Updates

Write-up published

Read it here

Resolved

An incident was reported at 7:17 am MT today, which resulted in slowness in several environments. For some Orgs, the Project Hub, Activity, and Project loading were temporarily unavailable. We have updated the status records to show some environments experiencing partial outages at this time.

The incident’s root cause was identified at 8:00 am MT. During our normal deployment on Thursday evening, a feature enhancement was released that resulted in unintended performance consequences. The full effects were not visible until the general user base began their daily activities within the system. This feature enhancement was removed this morning, and we were able to restore expected behavior across all environments by 8:40 am MT.

As a part of our standard incident review process, we will identify additional areas for improvement and optimization, including communications. We are grateful for your patience as we work to provide the best user experience.

Fri, Dec 9, 2022, 06:48 PM
2h earlier...

Resolved

All environments are restored to normal performance. The team identified the root cause in the latest update to the system and has removed the issue to prevent future occurrences.

Fri, Dec 9, 2022, 03:57 PM
42m earlier...

Identified

We have identified a cause, and were able to remediate. One environment is back to optimal performance and we are focusing efforts to ensure all return to expected speeds.

Fri, Dec 9, 2022, 03:15 PM
58m earlier...

Investigating

We are investigating reports of slowness in multiple environments. We are working urgently on the issue and will share an update as soon as possible.

Fri, Dec 9, 2022, 02:17 PM